Commit 8b5fa710 authored by Jan-Philipp Stauffert's avatar Jan-Philipp Stauffert
Browse files

Uploaded to RubyGems

parent e96482c5
......@@ -8,8 +8,8 @@ The HCI Theme packaged as a gem.
Add these lines to your Jekyll site's `Gemfile`:
```ruby
gem "hci-theme", :git => "git@gitlab2.informatik.uni-wuerzburg.de:hci-development/hci-theme.git"
gem "jekyll-img-srcset", :git => "git@gitlab2.informatik.uni-wuerzburg.de:hci-development/jekyll-img-srcset.git"
gem "hci-theme"
gem "jekyll-img-srcset"
```
And add these lines to your Jekyll site's `_config.yml`:
......@@ -28,6 +28,15 @@ Or install it yourself as:
$ gem install hci-theme
## Development Version
If you want to most up to date version of the theme use the git dependencies in your Gemfile.
```ruby
gem "hci-theme", :git => "git@gitlab2.informatik.uni-wuerzburg.de:hci-development/hci-theme.git"
gem "jekyll-img-srcset", :git => "git@gitlab2.informatik.uni-wuerzburg.de:hci-development/jekyll-img-srcset.git"
```
## Usage
### Menu
......
......@@ -8,21 +8,21 @@ Gem::Specification.new do |spec|
spec.email = ["jan-philipp.stauffert@uni-wuerzburg.de"]
spec.summary = "The HCI page theme."
spec.homepage = "https://hci.uni-wuerzburg.de"
spec.homepage = "https://gitlab2.informatik.uni-wuerzburg.de/hci-development/hci-theme"
spec.license = "Apache-2.0"
spec.files = FileList[
'_includes/*',
'_layouts/*',
'_sass/*',
'install.rb',
'extconf.rb',
'bibsonomy.js',
'entry.jsx',
'webpack.config.js'
].to_a
spec.add_runtime_dependency "jekyll", "~> 4.0"
spec.add_runtime_dependency 'jekyll-sass-converter'
spec.add_runtime_dependency 'jekyll-sass-converter', "~> 2.0"
spec.add_development_dependency "bundler", "~> 1.16"
spec.add_development_dependency "rake", "~> 12.0"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment